Alert Flash: IBM Notes/Domino Feature Pack 10


Today I received an Alert Flash regarding issues on IBM Notes/Domino Feature Pack 10 with the hint to stop upgrades. Currently the following issues are known:
  • (verified by L2) SMTP Mails with Umlauts broken after installing FP10                    This seems to be regression. Support is working.
  • (verified) Group iQ.Suite - Out of License because the internal product numbering has changed. The API reports a different version number.
    Before upgrade eg 9.0.1.9.0.0  => 9.0.1 FP9, after upgrade 900.0.11.0.0.0  => 9.0.1 FP10
    Group is informed and can assist. Group will provide Hotfixes of iQ.Suite (19.1.5, 20.2.3 or 20.3) soon.
  • (not yet verified) org.eclipse.core.runtime.CoreException: Plug-in http://com.ibm.domino.java .api was unable to load class http://com.ibm .domino.osgi.widgets.UpdateWidgetsTask.
    Also custom plugins are broken.
  • (not yet verified) DOTS Task is crashing during startup (OSGI Plugins disappear), s.a.a.
  • (not yet verified) Uninstall of FP10 not possible.
    From scratch reinstall required.
  • (pending) Regarding Mailsploit, the remediation will be included in an FP10 interim fix. Development working on it through SPR #JBAMATTKY3.
So it´s suggested to stop upgrading your environment at the moment.

Comments

  1. For the full Designer/admin client uninstall of FP10 is possible. (just did it today a couple of times to cleanly Modify the Install)

    ReplyDelete
  2. For basic client uninstall working too. Install FP10 on 9.0.1 w/o any FP, then uninstall FP10 by re-run setup, and install FP9

    ReplyDelete
  3. Hi Pavel, you're right. FP10 installer is also working after you do a clean install of 9.0.1 Standard Client and afterwards you install FP10. Only some upgrades from FP9 or especially with some Interim Fixes don't work.

    ReplyDelete
    Replies
    1. Oh, Notes do it as Domino :) (you coudn't install a FP on Domino if any IF was installed previously - you should uninstall IF first)

      Delete
  4. I'd have some issues to add:

    - all Sidebar widgets disappear after upgrading
    - the button "Search widget catalog" disappeared
    - I cannot open widgets in the sidebar after importing them from the widget catalog
    - Notes shows a "work space log" ("Arbeitsbereichprotokoll") in the right half of its window which cannot be closed.

    Unbelievable.

    ReplyDelete
    Replies
    1. Hi Oliver, that could link up with a "feature" of FP9, where the embedded browser is no longer available: https://www.ibm.com/support/knowledgecenter/en/SSKTWP_9.0.1/fram_what_new_FP9_r.html

      Delete
    2. Yep, with no embedded browser we are staying back at FP7 until we figure out how we can replace embedded experiences. There was no announcement of removing this feature, just finding it out the hard way after the fact. (Though I guess I should have deduced if there is no embedded browser there is no embedded experiences)
      When I asked in the domino2025 jam it was "removed due to low adoption" (unfortunately we adopted it! after being told 2 years ago by an IBMer (who checked for us) it wasn't going anywhere).
      I think what they really meant was they didn't have resources to fix whatever security problem they had with the embedded browser so just decided if there is no embedded browser then that have fixed the security problem.

      Delete
    3. Oliver, I had to clear out my notes.ini and delete my workspace folder to get mine to go away. I am NOT happy about that! I opened a PMR for the issue last week and support had never heard of this happening. :/

      Delete
  5. Another problem is with addons like Ytria ScanEZ suite, DomNavigator and Noteshound, which add a toolbar.
    On every start of the client, those toolbars which you carefully positioned next to the standard toolbars are now relegated to the second row. Ytria has confirmed seeing this also.

    ReplyDelete
  6. Possible source of fixpack failure found: the 9.0.1 installers and subsequent updates al trip over a space in the path of your windows user, e.g. 'C:\Users\John Doe\'

    Workaround:
    Set the Windows TMP and TEMP environment vars to 'C:\Users\JohnD\Temp'
    After you created the directory 'C:\Users\JohnD\Temp\' of course...
    PMRed it...

    ReplyDelete
    Replies
    1. Aha. Found root cause: newer versions of Windows default to 8dot3name creation turned off. Which causes problems with the old installer, because the path to the notesfixinstaller.log file is not quoted like the path to the msi file and the installation directory.
      So a better workaround is to create an 8dot3name for users with a space in the name, then the FP9 and up installers will work again. Because fiddling with the environment variables wil likely bite you in other, probably too interesting places.

      Delete
  7. There's also a problem with incresead DPI making Notes fuzzy.
    This technote explains what the problem is and how to solve it: http://www-01.ibm.com/support/docview.wss?uid=swg22009344 (for FP9)
    The problem with FP10 is the same, but the solution isn't working. I had to uninstall FP10 from my Admin client.

    ReplyDelete
  8. Raised PMR about installer issue: replied with a sugesstion to 'upgrade' an installer which is outdated and unavailable for any Windows version the Notes Client is supposed to run on. Citing an article by IBMs InstallShield supplier from IBM from 2008.

    Raised a PMR about the toolbars: recognized as SPR # YGAO8JHCKT and APAR LO62129 with no plans to fix.

    I'm glad we are saying goodbye to Domino ASAP. This is going nowhere fast.

    ReplyDelete

Post a Comment

Popular posts from this blog

IBM Notes/Domino 9.0.1 Feature Pack 10