Posts

Showing posts from August, 2017

Apache - Redirect based on IP tables

Some days ago I received the question of a customer, if it´s possible to use a Reverse Proxy to either redirect to an internal or an external server based on IP ranges. After some searches and help from Martin Leyrer ( thanks a lot for your suggestions ), I figured out the complete configuration file for this special customer.

If you need some URL redirection/rewriting, feel free to use this code ( suggestions for better ways to accomplish this request are highly welcome ):

<VirtualHost ip-address:80>
 ServerName server01.company.com

 # Redirect all requests to SSL
 Redirect permanent / https://server01.company.com

 ErrorLog /var/www/virtual/logs/portal.company.com_error.log
 CustomLog /var/www/virtual/logs/server01.company.com_access.log common
</VirtualHost>

<VirtualHost ip-address:443>
 ServerName server01.company.com
 SSLEngine On
 SSLProxyEngine On
 ProxyVia On
 ProxyRequests Off
 ProxyPreserveHost On
 ProxyErrorOverride On
 RewriteEngine On

 # Added due to HTTP 502 errors:
 # ht…

Sync database quotas between servers

Today I again had the issue, that Database Quotas have not been synced between IBM Domino Cluster servers. After some search, I found the following post:

http://tippner.blogspot.co.at/2011/08/synchronizing-database-quotas.html

I did some modifications in the code and ran the agent with the Server ID and scheduled the agent one time a day... So far it´s looking fine...

You can download the database here: https://www.dropbox.com/s/9ebh3r0qh4hl6ft/sync_dbquotas.nsf?dl=1




IBM Connections 5.5 CR3 upgrade issue

Image
Today I installed Connections 5.5 CR3 at customer site and followed the required steps here. I also followed the steps for creating the requested Dynacache for the Rich Text Editor:

http://www-01.ibm.com/support/docview.wss?uid=swg22001580

As mentioned I created the Dynacache just for the RTE-Cluster and figured out, that this led to problems for all single cluster member. 

So I removed the setting for the RTE-Cluster and added it for the complete cell:


After a restart of all cluster servers everything was fine again.